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CMZ 
(ARREDOCAD 
PROJECT FILE)

QUESTIONS

I cannot open a CMZ file that has been sent to me.

When I click on "Open project" in the list of saved projects, 
I cannot find a CMZ file imported into ArredoCAD.

I cannot open a CMZ file that has been sent to me.
1.	 This is the file format with which the projects created with ArredoCAD can be saved 

	 and opened only inside the program. To open a CMZ file, click on Advanced from

	 ArredoCAD Channel, then on Import CMZ project (for versions prior to the 14.5: 

	 Click on Advanced->Import scene internet). You can open a CMZ file from the work area 

	 of ArredoCAD clicking on File ->Import CMZ file (for versions prior to the 14.5: 

	 Click on the left on the top on File ->Open CMZ file). 

2. 	Be sure that you have created successfully the CMZ file (at the end of the operation 

	 the mouse cursor can be moved freely on the work area). If something went wrong, 

	 you can create another CMZ file.

When I click on "Open project" in the list of saved projects, 
I cannot find a CMZ file imported into ArredoCAD.
1. You have to bear in mind that the CMZ file is not visualized among the fields that identify 

	 the project (customer, reference etc).

2. Order the projects according to directory clicking on “Directory” (the first column at the

	 top) and open the project at the end of this list (the one with the directory that has 

	 the highest number).

3. Be sure that you have created successfully the CMZ file ( at the end of the operation the 

	 mouse cursor can be moved freely on the work area). If something went wrong, you can 

	 reate another CMZ file.
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ELEMENTS

QUESTIONS

I look for an element in the element list, but I don’t know in which folder it 
is contained. How can I search it rapidly?

When I use the command “Rotate element”, I don’t see the object.

I need to hook my object to a vertex or to the conjunction point resulting 
from 2 lines of an element for which there is no hook point available. How 
can I do?

I cannot cut an element.

I have created a customized element using the function Manually drown 
element. If I apply a texture, it cannot be visualized as I want (for ex. 
Vertical instead of horizontal, too big or to small etc.).

QUESTIONS

I have modified the project (colour change, doors, element position, 
insertion or elimination etc), but I cannot see the changes that I’ve done 
in the 3D window.

I cannot select or delete an object from the 2D window.

USING 
ARREDOCAD

ARREDOCAD FAQ / USING ARREDOCAD / ELEMENTS  
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I have created a customized element using the function Manually drown 
element. If I apply a texture, it cannot be visualized as I want (for ex. 
Vertical instead of horizontal, too big or to small etc.).
Once you have created the shape of the element and closed the last side pressing START on 

keyboard, you have to click on a point of the element and then on another to draw a segment: 

the direction and the length of such segment will determine the direction and the size of any 

texture you apply to the element. Be sure that you have drawn correctly the segment during 

element drawing.

I have modified the project (colour change, doors, element position, 
insertion or elimination etc), but I cannot see the changes that I’ve done 
in the 3D window.
From the work area of ArredoCAD click on Visualize->Update 3D project (from the version 14.5 

it is possible to use the rapid key, the first at the top of the left vertical command line        ). 

If the problem has not be yet solved, try to deactivate the 3D window temporarily clicking on 

Options, from the menu bar-> Preferences and delete the check from the box “3D window”.

I cannot select or delete an object from the 2D window.
Try to find the same element in the 3D window and select it. Alternatively, from the work area 

of ArredoCAD click on Visualize -> Update 3D project (from the version 14.5 it is possible to use 

the rapid key, the first at the top of the left vertical command line        ). If the problem persists, 

try to deactivate the 3D window temporarily clicking on Options from the menu bar-> 

Preferences and then delete the check mark from the box “3D window”.

I look for an element in the element list, but I don’t know in which folder it 
is contained. How can I search it rapidly?
From the element list click on “Search all” at the bottom on the right (when you enter for the first 

time you will be asked to create a database of the objects), insert a keyword (for ex. “cushion” or 

“hand-towel” etc.) in the field “Description” and click on “Browse”. Then select the object and 

insert manually or using Auto-mode. 

When I use the command “Rotate element”, I don’t see the object. 
Press the spacebar on the keyboard during rotation to visualize the object with all construction 

lines.

I need to hook my object to a vertex or to the conjunction point resulting 
from 2 lines of an element for which there is no hook point available. How 
can I do?
In the work area of ArredoCAD you have to activate the function          (hook point) that is on the 

right in the command vertical line and then press F2 on the keyboard. In this way on every vertex 

or conjunction point resulting from 2 lines of an element an automatic snap will be activated and 

visualized every time you pass on with the mouse. 

I cannot cut an element.
Be sure that the elements intersect correctly (check that their positions in plan view and in 

elevation view). After cutting delete the cutting element to check if the operation has been 

successfully.
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ERRORS

QUESTIONS

When I insert the activation code the message 
“Error 23. Expired product” appears.

When I insert the activation code the message 
“Error 33. Maximum number of licenses reached!” appears.

When I insert the activation code the message 
“Error 44. Product blocked!” appears

When I insert the activation code the message 
“Error 55. Product code not found” appears.

When I insert the activation code the message 
“Error 77. Version doesn't correspond” appears.

When I insert the activation code the message 
“Error 99. Customer reference doesn't exist” appears.

QUESTIONS

When I open the program the message
"Error BDE $2108" appears: What can I do?

"Error open table" appears when you open the program after 
that your PC suddenly shut off.

"Error 339" appears when you open the program or a project.

Problems visualizing the 3D window. When you use the mouse, you cannot 
move fluently in the 3D window or a bug report of Access violation appears 
after opening the program.

When you launch the render this message appears 
"Error: image not found" and the rendering engine doesn't start.

USING 
ARREDOCAD

ARREDOCAD FAQ / USING ARREDOCAD / ERRORS  
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When I insert the activation code the message 
“Error 99. Customer reference doesn't exist” appears.
The first 4 codes inserted are wrong. Check carefully that they are exactly the same ones 

that Dinamica Software sent you.

When I open the program the message 
"Error BDE $2108" appears: What can I do?
Something went wrong with installation. Enter the folder C:\dvd_arredocad\ BDE and launch 

with a double click the file instbde.bat. If you installed the program using DVD, visualize the 

content and launch the file instbde.bat contained in the DBE folder with a double click.

"Error open table" appears when you open the program after
that your PC suddenly shut off.
Install the program again to recover the damaged files. If the problem persists, please contact 

Dinamica Software.

"Error 339" appears when you open the program or a project. 
Enter the folder C:\dvd_arredocad\Utility and launch the file Errore339_64bit.BAT (or 

Errore339_32bit.BAT if your operative system is 32bit) with a double click. If you have installed 

the program using DVD, visualize the content and make a double click to launch the file 

Errore339_64bit.BAT (or Errore339_32bit.BAT if your operative system is 32bit) contained in the 

Utility folder.

When I insert the activation code the message 
“Error 23. Expired product” appears.
The period of validity of the license has expired. Contact Dinamica Software.

When I insert the activation code the message 
“Error 33. Maximum number of licenses reached!” appears.
It is possible that the license that you would like to activate is already in use in another PC. 

In this case, enter your Reserved Area, then recognize the license you want to activate 

and click on RESET to make it available again for activation in the new PC. 

When I insert the activation code the message 
“Error 44. Product blocked!” appears.
The product has been blocked by our server. Please contact Dinamica Software. 

When I insert the activation code the message 
“Error 55. Product code not found” appears.
The fifth code inserted is wrong. Check carefully that the codes are correct and that they 

are the same as those sent by Dinamica Software. If they are right you have received please 

contact Dinamica Software for telephonic support.

When I insert the activation code the message 
“Error 77. Version doesn't correspond” appears.
In this case you are not allowed to activate this version. Please contact Dinamica Software.

ARREDOCAD FAQ / USING ARREDOCAD / ERRORS  



80 81

EN
G

USING 
ARREDOCAD

When you launch the render this message appears 
"Error: image not found" and the rendering engine doesn't start.
Install all the files that begin with “vcredist” .exe contained in the folder C:\dvd_arredocad 

by making double click or, if you used a DVD to install the software, from the DVD folder after 

inserting in the DVD reader. It is a matter of libraries C++ that, sometimes, are not contained 

in the operative system. 

If the message should appear again, be sure that the project doesn’t contain the following 

errors:

- Overlapping walls.

-	 Windows, French-windows, doors and other elements that are embedded into the walls near

	 to the corner. You have to move them of some mm.

	 If the problem persists, please contact Dinamica Software.

Problems visualizing the 3D window. When you use the mouse, you 
cannot move fluently in the 3D window or a bug report of Access 
violation appears after opening the program.
These problems are caused by the graphic card used in your computer. Besides an integrated 

video card, you should use a graphic card with at least 2 GB supporting 3D and be sure that the 

drivers of the card are updated to the latest version. Moreover, from the control panel of the 

video card, check that you are using the dedicated video card by default and not the integrated 

one (not so powerful).

If you just have an integrated video card in your computer, you have to deactivate the 3D 

window (the other functionalities of ArredoCAD will keep on working as usual). To deactivate 

the 3D window, you have to click on Advanced in the ArredoCAD Channel and then delete the 

check from box “3D window”. Alternatively click on Options from the menu bar to visualize the 

command Preferences. 

If an error (bug report) doesn’t allow to enter Preferences when you open ArredoCAD, enter the 

folder C:\ArredoCAD, and delete the file Prefer.dat. After this rename the file Prefer_no_3d.dat 

in Prefer.dat. When you open ArredoCAD the 3D window is deactivated.

ARREDOCAD FAQ / USING ARREDOCAD / ERRORS  
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How can I activate the 3D window?

I cannot see the visualization of the project navigating 
in the 3D window.

How can I activate the 3D window?
From the work area of ArredoCAD, from the menu bar click on Options->Preferences and 

insert the check mark in the box “3D window”. 

I cannot see the visualization of the project navigating 
in the 3D window
Press the button F6 on the keyboard or select the button “restore point of view” in the 

command line on the right (        ).

The command move the object to the origin point again. This point corresponds to the 

symbol         that appears in the window of wall management, when you draw a plan. 

If the plan should be positioned far from the origin point for any reason, you can set the origin 

point again by clicking on Visualize in the menu bar-> insert origin scene and then you have to 

click on a new origin point.

3D WINDOW

QUESTIONS

ARREDOCAD FAQ / USING ARREDOCAD / 3D WINDOW  USING 
ARREDOCAD
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I downloaded a 3D file in .3ds or .skp to import into ArredoCAD. 
When I click on File -> Import 3DS and select the folder in which 
I saved the file, but I can’t visualize it. Or, when I click on File -> 
Import 3DS an error message appears.

I have imported a .3ds or a .skp file into ArredoCAD, but I cannot 
visualize it properly in the project (it’s overturned, rotated or it has 
problems when I apply a texture etc.).

When I import a .skp file, it cannot be laoded or an error 
message appears.

I downloaded a 3D file in .3ds or .skp to import into ArredoCAD. 
When I click on File -> Import 3DS and select the folder in which 
I saved the file, but I can’t visualize it. Or, when I click on File -> 
Import 3DS an error message appears.
1.	Be sure that the file extension is among them supported by ArredoCAD (.3ds and .skp).

	 	 If it is a zipped or compressed file, first of all extract it and then import it into ArredoCAD. 

2. 	Check that the name of the file doesn't contain empty spaces, characters with accents

	 	or special characters (for ex. Chinese or Cyrillic characters), and if it is so, rename it before

		  importing.

I have imported a .3ds or a .skp file into ArredoCAD, but I cannot 
visualize it properly in the project (it’s overturned, rotated or it has 
problems when I apply a texture etc.).
The imported file has wrong features that cannot be managed and modified by ArredoCAD. 

If possible, modify it with a 3D modeling software (for example SketchUp).

When I import a .skp file, it cannot be laoded or an error 
message appears. 
Try to import the same .skp file but try to save it with a previous version of SketchUp.  

For example, if the .skp file has been saved with the 2018 version, try to import the same

file saved with the version of 2017.

3DS AND SKP 
FILE IMPORTING

QUESTIONS

ARREDOCAD FAQ / USING ARREDOCAD / 3DS AND SKP FILE IMPORTINGUSING 
ARREDOCAD
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I've imported a .dxf or .dxg of a plan, but I cannot visualize it.

I’ve imported the .dxf or .dwg of a plan but while drawing 
a wall I notice that the right scale has not be used (for example 
the plan is too small).

I've imported a .dxf or .dxg of a plan into a project. 
When I open it again, I cannot visualize the imported plan.

I've imported a .dxf or .dxg of a plan, but I cannot visualize it.
1.	Be sure that the .dxf or .dwg file is two-dimensional, that is 2D and not 3D, as specified

	 	 in the command to import (File->Import DWG/DXF 2D). 

2. If it is 2D, be sure that you have inserted a value of scale in the upper part of the import

		 window that is compatible with the real measures of the plan, showed in millimeters. 

3. Be sure that the file is not too "heavy". If it is, you can try to delete elements that are 

	 	not necessary (like sections, written parts, hatches …).

4. 	If the plan is visualized partially and there are some parts that are missing, you may open

	 	 the .dxf or .dwg file with a third program (for example Autocad), select the whole file

	 	content and execute the command Explode, once or several times. Save and close the file 

		  to import into ArredoCAD. 

I’ve imported the .dxf or .dwg of a plan but while drawing a wall I notice 
that the right scale has not be used (for example the plan is too small).
Be sure that you have inserted a scale compatible with the real measures 

of the plan, indicated in millimeters, in the upper part of the window for importing. 

I've imported a .dxf or .dxg of a plan into a project. 
When I open it again, I cannot visualize the imported plan. 
From the work area of ArredoCAD click on Visualize->2D DWG/DXF PLAN ->

Visualize 2D DWG/DXF PLAN .

DWG AND DXF 
IMPORTING

QUESTIONS

ARREDOCAD FAQ / USING ARREDOCAD / DWG AND DXF IMPORTINGUSING 
ARREDOCAD
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I need to modify the height of the walls that I have already drawn.

I have two out-of-square walls, but I cannot visualize the letters/characters 
on the corner of the plan.

I've created a Construction/Transparent wall, but covering/tiling 
is rotated in the opposite direction. 

My project in elevation or plan view is not centered on the work area 
(though I have activated the command "Zoom All").

I need to modify the height of the walls that I have already drawn.
Enter Wall Management and in the column of the commands on the left         (select walls). 

Select the walls of which you want to change height, from the menu bar click on Walls->Apply 

wall height, insert a new value in millimeters and confirm with OK. 

If a wall has been already selected as working wall, you have to click on Walls->Wall list, select 

“Edit” and modify the measure in millimeters in the field of the column “Height”, so click on 

“Save” and close by clicking on “OK”.

I have two out-of-square walls, but I cannot visualize the letters/characters 
on the corner of the plan.
Select at least one of the two walls as "working wall" to allow the program to calculate the 

angle of the opening, that will be automatically indicated in the plan view.

I've created a Construction/Transparent wall, but covering/tiling 
is rotated in the opposite direction. 
From the work area of ArredoCAD, in the menu bar click on Walls->Wall orientation and then 

click on the wall you have to modify, to change orientation.

WALLS

QUESTIONS

ARREDOCAD FAQ / USING ARREDOCAD / WALLSUSING 
ARREDOCAD
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My project in elevation or plan view is not centered on the work area 
(though I have activated the command "Zoom All").
If the problem has to do with the elevation view of a wall, from the work area of ArredoCAD 

click on Walls in the menu bar -> Wall numbers on to identify the number of the wall. 

Then from the menu bar click on Options -> Project element list, if possibile, recognize and 

delete the eventual object that has not been properly matched to the wall (not visualized, 

though contained in the project), or the rest of a previously exploded element.

If the problem deals with the plan, on the work area check carefully if there are objects or walls 

that are in a wrong position - outside the plan. To do this, click on Zoom or Move element. 

Pay attention: Maybe they are really small!
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I don't want to visualize the dimensions that the software 
insert automatically.

I have inserted the dimensions of the electrical plant, 
but now I cannot see the other dimensions.

I would like to insert a 2D dimension, line or arrow manually. 
How can I do?

DIMENSIONS

QUESTIONS

USING 
ARREDOCAD

I don't want to visualize the dimensions that the software 
insert automatically.
From the work area of ArredoCAD click on Options in the menu bar -> Preferences and 

remove the check mark from the box "Automatic dimensions" in the upper part of the window 

on the left.

I have inserted the dimensions of the electrical plant, 
but now I cannot see the other dimensions.
From the work area of ArredoCAD click on Options in the menu bar -> Electrical system 

dimensions" and remove the check mark from the box "Visualize only electrical system 

dimensions".

I would like to insert a 2D dimension, line or arrow manually. 
How can I do?
Make right mouse click inside the work area of ArredoCAD. A menu for rapid dial will appear. 

Select "Dimensions" and the option you like to use. Then click with the mouse to mark the 

beginning and the end of the element for which you want to visualize dimensions.

ARREDOCAD FAQ / USING ARREDOCAD / DIMENSIONS
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Can I save projects in another pc (for example a server)?

Can I share images imported into the program ArredoCAD 
in the network?

NETWORK

QUESTIONS

ARREDOCAD FAQ / USING ARREDOCAD / NETWORKUSING 
ARREDOCAD

I don't want to visualize the dimensions that the software 
insert automatically.
Yes, you can. You can share projects in a network and the images that you imported. 

Search for the folder ArredoCAD contained in the computer in which you would like to save 

your projects. Open it and then open the file DINAMRIV.CFG that looks like this:

DEFAULT:       .\DEFAULT

LAVORI:          .\LAVORIR

HOST:              .\LAVORIR\HOSTR

TESTATE:         .\LAVORIR\TESTATER

USER:               .\

Modify the file as follows:
in LAVORI substitute the fullstop with // and add the name of the computer on which all 

projects should be saved (for ex. DINAMICA), followed by \ARREDOCAD\LAVORIR

DEFAULT:       .\DEFAULT

LAVORI:          \\DINAMICA\ARREDOCAD\LAVORIR

HOST:              .\LAVORIR\HOSTR

TESTATE:  \\DINAMICA\ARREDOCAD\LAVORIR\TESTATER

USER:               .\

The modified file DINAMRIV.CFG  should be saved and overwritten in all computers 

connected to the network (excepted the server computer) in which ArredoCAD has 

been installed, so that every time you will save a project from any of these PCs, it will be 

automatically saved on the main computer that you chose. Then, open the program on this 
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PC, click on FILE in the menu bar, then on ADVANCED and then click on UPDATE 3D SCENE 

to be able to visualize all projects saved.

If you open a project from inside the program installed on one of the computer connected to 

the server, and you see the error message "ERROR 52 Bad file name number", please check 

the paths already set in the file DINAMRIV.CFG because they are probably not correct or they 

contain errors.

Can I share images imported into the program ArredoCAD 
in the network?
To share imported images, from the work area of ArredoCAD click on Options in the menu 

bar -> Preferences insert set a check mark in the box "Manage LAN textures". This operation 

should be done for all the licenses of ArredoCAD that are funtioning in the network, that is, 

in the network in which users save their projects in a common path. You have to consider that 

from the version 14 of ArredoCAD the exportation of a project in CMZ format include the 

transfer of images imported into the project.
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How can I insert my logo in the quotation or in the technical prints 
of the project created with ArredoCAD?

How can I modify the name of the model in the titleblock contained 
in technical prints created with ArredoCAD?

TECHNICAL 
PRINTS

QUESTIONS

USING 
ARREDOCAD

How can I insert my logo in the quotation or in the technical prints 
of the project created with ArredoCAD?
From the work area of ArredoCAD click on Options in the menu bar ->Preferences. 

Then click on "Browse" (right section) and select the file that you want to use as logo for prints 

and project data titleblock. The file can be imported in the .jpg, .bmp or .png. format.

How can I modify the name of the model in the titleblock contained 
in technical prints created with ArredoCAD?
From the work area of ArredoCAD click on FILE-> Modify titleblock and fill in the field 

"DESCRIPTION PRINTS". If this field has no text or image, the name of the main model used 

in the project will be inserted automatically.

ARREDOCAD FAQ / USING ARREDOCAD / TECHNICAL PRINTS
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How can I insert a 2D (two-dimensional) text?

How can I insert a 3D (three-dimensional) text?

2D AND 3D 
TEXTS

QUESTIONS

USING 
ARREDOCAD

How can I insert a 2D (two-dimensional) text?
From the work area of ArredoCAD click on TEXT-> then insert your text. 

Make a mouse click to create a line - in plan or elevation view - so that you can orientate 

the text and set the length. Then you can write a text in the window that will 

appear automatically.

How can I insert a 3D (three-dimensional) text?
From the element list enter in "Shared accessories", select the folder Construction 

polygons -> 3D numbers and symbols, insert in the desired position of the project 

the element "3D texts" and keep on inserting automatically the text. 

ARREDOCAD FAQ / USING ARREDOCAD / 2D AND 3D TEXTS
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How can I change the program? 

If I have made a mistake during planning, can I undo the operation and 
restore the previous situation?

Do the software execute automatic saving?

I have importaed an image from the Internet into the material library, 
but I cannot see it properly.

My antivirus has deleted the program. What shall I have to do?

VARIOUS 

QUESTIONS

USING 
ARREDOCAD

How can I change the program? 
From the work area of ArredoCAD click on Options -> Preferences-> language and select 

among the available ones the one you like. To make the modification effective you have 

to close and open the program again. 

If I have made a mistake during planning, can I undo the operation 
and restore the previous situation?
Yes, you can: from the work area of ArredoCAD click on Options in the menu bar-

>Preferences-> and insert the check mark in the box "Undo/Redo". From this moment 

on you will be able to go back to previous planning stages by clicking in the menu bar 

on the command        "Undo/Redo" from the work area of ArredoCAD. 

The software can keep track of at most 5 actions.  

Do the software execute automatic saving?
No, it doesn't. ArredoCAD allows to recover automatically the project in case of abruptly 

shutting down of the program or in case of computer crash. If this happens, please contact 

DINAMICA SOFTWARE immediately without performing any further action, that could 

damage definitively the project.

I have importaed an image from the Internet into the material library, 
but I cannot see it properly.
Open the image from C:\Arredocad\FILEBMP using the program Paint (from Windows 

accessories). Then click on FILE->Save as and then select the BMP -Bitmap 24 bit- format 

by confirming the substitution of the file.

My antivirus has deleted the program. What shall I have to do?
Check the settings of your antivirus and add the file Arredocad.exe or the whole directory to 

the esclusions or excepions. Then, if you cannot recover the deleted files, you have to install 

the program again using the DVD you received from DINAMICA SOFTWARE.

ARREDOCAD FAQ / USING ARREDOCAD / VARIOUS 
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